CVEvulnerability
CVE-2005-10002
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-10-29
- Last modified
- 2026-06-16
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 5.2 MEDIUM — AV:A/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-22
Description
A vulnerability, which was classified as critical, was found in almosteffortless secure-files Plugin up to 1.1 on WordPress. Affected is the function sf_downloads of the file secure-files.php. The manipulation of the argument downloadfile leads to path traversal. Upgrading to version 1.2 is able to address this issue. The name of the patch is cab025e5fc2bcdad8032d833ebc38e6bd2a13c92. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-243804.
Affected configurations
• wp-plugins secure files (< 1.2)
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/wp-plugins/secure-files/commit/cab025e5fc2bcdad8032d833ebc38e6bd2a13c92 Patch
- https://vuldb.com/?ctiid.243804 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.243804 Third Party Advisory
- https://github.com/wp-plugins/secure-files/commit/cab025e5fc2bcdad8032d833ebc38e6bd2a13c92 Patch
- https://vuldb.com/?ctiid.243804 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.243804 Third Party Advisory