CVEvulnerability
CVE-2007-10003
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-10-29
- Last modified
- 2026-06-16
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-89
Description
A vulnerability, which was classified as critical, has been found in The Hackers Diet Plugin up to 0.9.6b on WordPress. This issue affects some unknown processing of the file ajax_blurb.php of the component HTTP POST Request Handler. The manipulation of the argument user leads to sql injection. The attack may be initiated remotely. Upgrading to version 0.9.7b is able to address this issue. The patch is named 7dd8acf7cd8442609840037121074425d363b694. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-243803.
Affected configurations
• wp-plugins the hackers diet (< 0.9.7b)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/wp-plugins/the-hackers-diet/commit/7dd8acf7cd8442609840037121074425d363b694 Patch
- https://github.com/wp-plugins/the-hackers-diet/releases/tag/0.9.7b Release Notes
- https://vuldb.com/?ctiid.243803 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.243803 Third Party Advisory
- https://github.com/wp-plugins/the-hackers-diet/commit/7dd8acf7cd8442609840037121074425d363b694 Patch
- https://github.com/wp-plugins/the-hackers-diet/releases/tag/0.9.7b Release Notes
- https://vuldb.com/?ctiid.243803 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.243803 Third Party Advisory