CVEvulnerability
CVE-2014-125051
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-01-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 5.2 MEDIUM — AV:A/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-89
Description
A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 is able to address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.
Affected configurations
• yii2-jqgrid-widget project yii2-jqgrid-widget (< 1.0.8)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/himiklab/yii2-jqgrid-widget/commit/a117e0f2df729e3ff726968794d9a5ac40e660b9 Patch, Third Party Advisory
- https://github.com/himiklab/yii2-jqgrid-widget/releases/tag/1.0.8 Third Party Advisory
- https://vuldb.com/?ctiid.217564 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.217564 Permissions Required, Third Party Advisory
- https://github.com/himiklab/yii2-jqgrid-widget/commit/a117e0f2df729e3ff726968794d9a5ac40e660b9 Patch, Third Party Advisory
- https://github.com/himiklab/yii2-jqgrid-widget/releases/tag/1.0.8 Third Party Advisory
- https://vuldb.com/?ctiid.217564 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.217564 Permissions Required, Third Party Advisory