CVEvulnerability

CVE-2014-125055

5.3 MEDIUM Published 2023-01-07 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-01-07
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
2.6 LOW — CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 3.1 ([email protected])
5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0 ([email protected])
1.4 LOW — AV:A/AC:H/Au:S/C:P/I:N/A:N
Weaknesses
CWE-208

Description

A vulnerability, which was classified as problematic, was found in agnivade easy-scrypt. Affected is the function VerifyPassphrase of the file scrypt.go. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0.0 is able to address this issue. The name of the patch is 477c10cf3b144ddf96526aa09f5fdea613f21812. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217596.

Affected configurations

• easy-script project easy-script (< 1.0.0)

Related

Weakness · CWE (1)

  • CWE-208 Observable Timing Discrepancy weakness

References