CVEvulnerability
CVE-2014-125079
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-01-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 5.2 MEDIUM — AV:A/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-89
Description
A vulnerability was found in agy pontifex.http. It has been declared as critical. This vulnerability affects unknown code of the file lib/Http.coffee. The manipulation leads to sql injection. Upgrading to version 0.1.0 is able to address this issue. The name of the patch is e52a758f96861dcef2dabfecb9da191bb2e07761. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218356.
Affected configurations
• pontifex.http project pontifex.http (< 0.1.0)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/agy/pontifex.http/commit/e52a758f96861dcef2dabfecb9da191bb2e07761 Patch, Third Party Advisory
- https://github.com/agy/pontifex.http/releases/tag/v0.1.0 Third Party Advisory
- https://vuldb.com/?ctiid.218356 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.218356 Permissions Required, Third Party Advisory
- https://github.com/agy/pontifex.http/commit/e52a758f96861dcef2dabfecb9da191bb2e07761 Patch, Third Party Advisory
- https://github.com/agy/pontifex.http/releases/tag/v0.1.0 Third Party Advisory
- https://vuldb.com/?ctiid.218356 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.218356 Permissions Required, Third Party Advisory