CVEvulnerability

CVE-2015-10009

9.8 CRITICAL Published 2023-01-02 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-01-02
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.5 MEDIUM — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
5.2 MEDIUM — AV:A/AC:L/Au:S/C:P/I:P/A:P
Weaknesses
CWE-94

Description

A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.

Affected configurations

• nonfiction nterchange (< 4.1.1)

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References