CVEvulnerability
CVE-2015-10030
5.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-01-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS 2.0 ([email protected])
- 5.2 MEDIUM — AV:A/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-21, CWE-22
Description
A vulnerability has been found in SUKOHI Surpass and classified as critical. This vulnerability affects unknown code of the file src/Sukohi/Surpass/Surpass.php. The manipulation of the argument dir leads to pathname traversal. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as d22337d453a2a14194cdb02bf12cdf9d9f827aa7. It is recommended to upgrade the affected component. VDB-217642 is the identifier assigned to this vulnerability.
Affected configurations
• surpass project surpass (< 1.0.0)
Related
Weakness · not in database (1)
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/SUKOHI/Surpass/commit/d22337d453a2a14194cdb02bf12cdf9d9f827aa7 Patch, Third Party Advisory
- https://github.com/SUKOHI/Surpass/releases/tag/1.0.0 Release Notes, Third Party Advisory
- https://vuldb.com/?ctiid.217642 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.217642 Permissions Required, Third Party Advisory
- https://github.com/SUKOHI/Surpass/commit/d22337d453a2a14194cdb02bf12cdf9d9f827aa7 Patch, Third Party Advisory
- https://github.com/SUKOHI/Surpass/releases/tag/1.0.0 Release Notes, Third Party Advisory
- https://vuldb.com/?ctiid.217642 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.217642 Permissions Required, Third Party Advisory