CVEvulnerability
CVE-2015-10094
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-03-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 2.4 LOW — CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 3.3 LOW — AV:N/AC:L/Au:M/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.
Affected configurations
• fastly fastly (< 0.98)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/wp-plugins/fastly/commit/d7fe42538f4d4af500e3af9678b6b06fba731656 Patch
- https://github.com/wp-plugins/fastly/releases/tag/0.98 Release Notes
- https://vuldb.com/?ctiid.222326 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222326 Third Party Advisory
- https://github.com/wp-plugins/fastly/commit/d7fe42538f4d4af500e3af9678b6b06fba731656 Patch
- https://github.com/wp-plugins/fastly/releases/tag/0.98 Release Notes
- https://vuldb.com/?ctiid.222326 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222326 Third Party Advisory