CVEvulnerability
CVE-2015-10096
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-03-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.0 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 4.6 MEDIUM — AV:N/AC:H/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-77
Description
A vulnerability, which was classified as critical, was found in Zarthus IRC Twitter Announcer Bot up to 1.1.0. This affects the function get_tweets of the file lib/twitterbot/plugins/twitter_announcer.rb. The manipulation of the argument tweet leads to command injection. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.1.1 is able to address this issue. The patch is named 6b1941b7fc2c70e1f40981b43c84a2c20cc12bd3. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-223383.
Affected configurations
• irc twitter announcer bot project irc twitter announcer bot 1.0.0
Related
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://github.com/Zarthus/irc-twitter-bot/commit/6b1941b7fc2c70e1f40981b43c84a2c20cc12bd3 Patch
- https://github.com/Zarthus/irc-twitter-bot/releases/tag/v1.1.1 Release Notes
- https://vuldb.com/?ctiid.223383 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.223383 Third Party Advisory
- https://github.com/Zarthus/irc-twitter-bot/commit/6b1941b7fc2c70e1f40981b43c84a2c20cc12bd3 Patch
- https://github.com/Zarthus/irc-twitter-bot/releases/tag/v1.1.1 Release Notes
- https://vuldb.com/?ctiid.223383 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.223383 Third Party Advisory