CVEvulnerability

CVE-2015-1330

6.8 MEDIUM Published 2015-07-01 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2015-07-01
Last modified
2026-06-17
Assigner
[email protected]
CVSS 2.0 ([email protected])
6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
Weaknesses
CWE-287

Description

unattended-upgrades before 0.86.1 does not properly authenticate packages when the (1) force-confold or (2) force-confnew dpkg options are enabled in the DPkg::Options::* apt configuration, which allows remote man-in-the-middle attackers to upload and execute arbitrary packages via unspecified vectors.

Affected configurations

• canonical ubuntu linux 12.04 • canonical ubuntu linux 14.04 • canonical ubuntu linux 14.10 • canonical ubuntu linux 15.04 • debian unattended-upgrades (<= 0.86)

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References