CVEvulnerability
CVE-2016-3993
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2016-05-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.5 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-119
Description
Off-by-one error in the __imlib_MergeUpdate function in lib/updates.c in imlib2 before 1.4.9 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted coordinates.
Affected configurations
• enlightenment imlib2 (<= 1.4.8)
• debian debian linux 7.0
• debian debian linux 8.0
Related
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- http://lists.opensuse.org/opensuse-updates/2016-05/msg00076.html lists.opensuse.org
- http://www.debian.org/security/2016/dsa-3555 www.debian.org
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=819818 bugs.debian.org
- https://git.enlightenment.org/legacy/imlib2.git/commit/?id=ce94edca1ccfbe314cb7cd9453433fad404ec7ef git.enlightenment.org
- https://sourceforge.net/p/enlightenment/mailman/message/35055012/ sourceforge.net
- http://lists.opensuse.org/opensuse-updates/2016-05/msg00076.html lists.opensuse.org
- http://www.debian.org/security/2016/dsa-3555 www.debian.org
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=819818 bugs.debian.org
- https://git.enlightenment.org/legacy/imlib2.git/commit/?id=ce94edca1ccfbe314cb7cd9453433fad404ec7ef git.enlightenment.org
- https://sourceforge.net/p/enlightenment/mailman/message/35055012/ sourceforge.net