CVEvulnerability
CVE-2016-9686
5.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2017-02-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 5.3 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-20
Description
The Puppet Communications Protocol (PCP) Broker incorrectly validates message header sizes. An attacker could use this to crash the PCP Broker, preventing commands from being sent to agents. This is resolved in Puppet Enterprise 2016.4.3 and 2016.5.2.
Affected configurations
• puppet puppet enterprise (>= 2016.4.0 < 2016.4.3)
• puppet puppet enterprise 2016.5.1
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://puppet.com/security/cve/cve-2016-9686 Vendor Advisory
- https://puppet.com/security/cve/cve-2016-9686 Vendor Advisory