CVEvulnerability

CVE-2017-1000376

7.0 HIGH Published 2017-06-19 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2017-06-19
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.0 HIGH — CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
6.9 MEDIUM — AV:L/AC:M/Au:N/C:C/I:C/A:C
Weaknesses
CWE-119

Description

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

Affected configurations

• redhat enterprise virtualization server • redhat openshift 2.0 • redhat enterprise linux 6.0 • redhat enterprise linux 7.0 • debian debian linux 8.0 • debian debian linux 9.0 • libffi project libffi (< 3.2) • oracle peopletools 8.56 • oracle peopletools 8.57

Related

Weakness · CWE (1)

  • CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness

References