CVEvulnerability

CVE-2017-12612

7.8 HIGH Published 2017-09-13 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2017-09-13
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
7.8 HIGH — CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.2 HIGH — AV:L/AC:L/Au:N/C:C/I:C/A:C
Weaknesses
CWE-502

Description

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

Affected configurations

• apache spark 1.6.0 • apache spark 1.6.1 • apache spark 1.6.2 • apache spark 1.6.3 • apache spark 2.0.0 • apache spark 2.0.1 • apache spark 2.0.2 • apache spark 2.1.0 • apache spark 2.1.1

Related

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References