CVEvulnerability

CVE-2017-14589

9.6 CRITICAL Published 2017-12-13 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2017-12-13
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
9.6 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CVSS 2.0 ([email protected])
6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
Weaknesses
CWE-20

Description

It was possible for double OGNL evaluation in FreeMarker templates through Struts FreeMarker tags to occur. An attacker who has restricted administration rights to Bamboo or who hosts a website that a Bamboo administrator visits, is able to exploit this vulnerability to execute Java code of their choice on systems that run a vulnerable version of Bamboo. All versions of Bamboo before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.

Affected configurations

• atlassian bamboo (< 6.1.6) • atlassian bamboo (>= 6.2.0 < 6.2.5)

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References