CVEvulnerability

CVE-2017-14590

9.1 CRITICAL Published 2017-12-13 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2017-12-13
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
9.1 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
CVSS 2.0 ([email protected])
9.0 HIGH — AV:N/AC:L/Au:S/C:C/I:C/A:C

Description

Bamboo did not check that the name of a branch in a Mercurial repository contained argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan that has a non-linked Mercurialrepository, create or edit a plan when there is at least one linked Mercurial repository that the attacker has permission to use, or commit to a Mercurial repository used by a Bamboo plan which has branch detection enabled can execute code of their choice on systems that run a vulnerable version of Bamboo Server. Versions of Bamboo starting with 2.7.0 before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.

Affected configurations

• atlassian bamboo (>= 2.7.0 < 6.1.6) • atlassian bamboo (>= 6.2.0 < 6.2.5)

References