CVEvulnerability

CVE-2017-15655

9.6 CRITICAL Published 2018-01-31 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-01-31
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
9.6 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CVSS 2.0 ([email protected])
9.3 HIGH — AV:N/AC:M/Au:N/C:C/I:C/A:C
Weaknesses
CWE-119

Description

Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version <=3.0.0.4.376.X. All have been fixed in version 3.0.0.4.378, but this vulnerability was not previously disclosed. Some end-of-life routers have this version as the newest and thus are vulnerable at this time. This vulnerability allows for RCE with administrator rights when the administrator visits several pages.

Affected configurations

• asus asuswrt (< 3.0.0.4.378)

Related

Weakness · CWE (1)

  • CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness

References