CVEvulnerability

CVE-2017-15708

9.8 CRITICAL Published 2017-12-11 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2017-12-11
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
Weaknesses
CWE-74

Description

In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.

Affected configurations

• apache synapse 1.0 • apache synapse 1.1 • apache synapse 1.1.1 • apache synapse 1.1.2 • apache synapse 1.2 • apache synapse 2.0.0 • apache synapse 2.1.0 • apache synapse 3.0.0 • oracle financial services market risk measurement and management 8.0.6 • oracle financial services market risk measurement and management 8.0.8 • oracle peoplesoft enterprise peopletools 8.56 • oracle peoplesoft enterprise peopletools 8.57

Related

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References