CVEvulnerability
CVE-2017-16810
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2017-11-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 5.4 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 3.5 LOW — AV:N/AC:M/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
Cross-site scripting (XSS) vulnerability in the All Variables tab in Octopus Deploy 3.4.0-3.13.6 (fixed in 3.13.7) allows remote attackers to inject arbitrary web script or HTML via the Variable Set Name parameter.
Affected configurations
• octopus octopus deploy (>= 3.4.0 <= 3.13.6)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/OctopusDeploy/Issues/issues/3919 Exploit, Third Party Advisory
- https://github.com/OctopusDeploy/Issues/issues/3919 Exploit, Third Party Advisory