CVEvulnerability
CVE-2017-20181
5.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-03-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:L/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-22
Description
A vulnerability classified as critical was found in hgzojer Vocable Trainer up to 1.3.0 on Android. This vulnerability affects unknown code of the file src/at/hgz/vocabletrainer/VocableTrainerProvider.java. The manipulation leads to path traversal. Attacking locally is a requirement. Upgrading to version 1.3.1 is able to address this issue. The name of the patch is accf6838078f8eb105cfc7865aba5c705fb68426. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222328.
Affected configurations
• vocable trainer project vocable trainer (< 1.3.1)
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/hgzojer/vocabletrainer/commit/accf6838078f8eb105cfc7865aba5c705fb68426 Patch
- https://github.com/hgzojer/vocabletrainer/releases/tag/v1.3.1 Release Notes
- https://vuldb.com/?ctiid.222328 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222328 Third Party Advisory
- https://github.com/hgzojer/vocabletrainer/commit/accf6838078f8eb105cfc7865aba5c705fb68426 Patch
- https://github.com/hgzojer/vocabletrainer/releases/tag/v1.3.1 Release Notes
- https://vuldb.com/?ctiid.222328 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222328 Third Party Advisory