CVEvulnerability
CVE-2017-2297
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-02-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.5 HIGH — CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.0 MEDIUM — AV:N/AC:M/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-287
Description
Puppet Enterprise versions prior to 2016.4.5 and 2017.2.1 did not correctly authenticate users before returning labeled RBAC access tokens. This issue has been fixed in Puppet Enterprise 2016.4.5 and 2017.2.1. This only affects users with labeled tokens, which is not the default for tokens.
Affected configurations
• puppet puppet enterprise (< 2016.4.5)
• puppet puppet enterprise 2016.5.1
• puppet puppet enterprise 2016.5.2
• puppet puppet enterprise 2017.1.0
• puppet puppet enterprise 2017.1.1
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://puppet.com/security/cve/cve-2017-2297 Vendor Advisory
- https://puppet.com/security/cve/cve-2017-2297 Vendor Advisory