CVEvulnerability

CVE-2017-3731

7.5 HIGH Published 2017-05-04 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2017-05-04
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
Weaknesses
CWE-125

Description

If an SSL/TLS server or client is running on a 32-bit host, and a specific cipher is being used, then a truncated packet can cause that server or client to perform an out-of-bounds read, usually resulting in a crash. For OpenSSL 1.1.0, the crash can be triggered when using CHACHA20/POLY1305; users should upgrade to 1.1.0d. For Openssl 1.0.2, the crash can be triggered when using RC4-MD5; users who have not disabled that algorithm should update to 1.0.2k.

Affected configurations

• openssl openssl 1.1.0a • openssl openssl 1.1.0b • openssl openssl 1.1.0c • openssl openssl 1.0.2 • openssl openssl 1.0.2a • openssl openssl 1.0.2b • openssl openssl 1.0.2c • openssl openssl 1.0.2d • openssl openssl 1.0.2e • openssl openssl 1.0.2f • openssl openssl 1.0.2h • openssl openssl 1.0.2i • openssl openssl 1.0.2j • nodejs node.js (>= 4.0.0 <= 4.1.2) • nodejs node.js (>= 4.2.0 < 4.7.3) • nodejs node.js (>= 5.0.0 <= 5.12.0) • nodejs node.js (>= 6.0.0 <= 6.8.1) • nodejs node.js (>= 6.9.0 < 6.9.5) • nodejs node.js (>= 7.0.0 < 7.5.0)

Related

Weakness · CWE (1)

  • CWE-125 Out-of-bounds Read weakness

References