CVEvulnerability
CVE-2017-6929
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2018-03-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 6.1 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.
Affected configurations
• drupal drupal (>= 7.0 < 7.57)
• drupal drupal (>= 8.0.0 < 8.4.0)
• debian debian linux 7.0
• debian debian linux 8.0
• debian debian linux 9.0
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html Issue Tracking
- https://www.debian.org/security/2018/dsa-4123 Third Party Advisory
- https://www.drupal.org/sa-core-2018-001 Mitigation, Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html Issue Tracking
- https://www.debian.org/security/2018/dsa-4123 Third Party Advisory
- https://www.drupal.org/sa-core-2018-001 Mitigation, Vendor Advisory