CVEvulnerability

CVE-2017-7478

7.5 HIGH Published 2017-05-15 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2017-05-15
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
7.5 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
Weaknesses
CWE-20, CWE-617

Description

OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.

Affected configurations

• openvpn openvpn 2.3.12 • openvpn openvpn 2.3.13 • openvpn openvpn 2.3.14 • openvpn openvpn 2.4.0 • openvpn openvpn 2.4.1

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-617 Reachable Assertion weakness

References