CVEvulnerability

CVE-2018-1000073

7.5 HIGH Published 2018-03-13 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-03-13
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
7.5 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:P/I:N/A:N
Weaknesses
CWE-59

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

Affected configurations

• rubygems rubygems (<= 2.2.9) • rubygems rubygems (<= 2.3.6) • rubygems rubygems (<= 2.4.3) • rubygems rubygems (<= 2.5.0)

Related

Weakness · CWE (1)

  • CWE-59 Improper Link Resolution Before File Access weakness

References