CVEvulnerability
CVE-2018-1000217
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2018-08-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 9.8 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-416
Description
Dave Gamble cJSON version 1.7.3 and earlier contains a CWE-416: Use After Free vulnerability in cJSON library that can result in Possible crash, corruption of data or even RCE. This attack appear to be exploitable via Depends on how application uses cJSON library. If application provides network interface then can be exploited over a network, otherwise just local.. This vulnerability appears to have been fixed in 1.7.4.
Affected configurations
• davegamble cjson (< 1.7.4)
Related
Weakness · CWE (1)
- CWE-416 Use After Free weakness
References
- https://github.com/DaveGamble/cJSON/issues/248 Exploit, Third Party Advisory
- https://github.com/DaveGamble/cJSON/issues/248 Exploit, Third Party Advisory