CVEvulnerability
CVE-2018-1000221
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2018-08-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 9.8 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-119
Description
pkgconf version 1.5.0 to 1.5.2 contains a Buffer Overflow vulnerability in dequote() that can result in dequote() function returns 1-byte allocation if initial length is 0, leading to buffer overflow. This attack appear to be exploitable via specially crafted .pc file. This vulnerability appears to have been fixed in 1.5.3.
Affected configurations
• pkgconf pkgconf (>= 1.5.0 <= 1.5.2)
Related
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://git.dereferenced.org/pkgconf/pkgconf/pulls/3 Third Party Advisory
- https://git.dereferenced.org/pkgconf/pkgconf/pulls/3 Third Party Advisory