CVEvulnerability

CVE-2018-1000300

9.8 CRITICAL Published 2018-05-24 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-05-24
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
9.8 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
Weaknesses
CWE-787

Description

curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.

Affected configurations

• haxx curl (>= 7.54.1 <= 7.59.0) • canonical ubuntu linux 14.04 • canonical ubuntu linux 16.04 • canonical ubuntu linux 17.10 • canonical ubuntu linux 18.04

Related

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References