CVEvulnerability
CVE-2018-1000400
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-05-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 8.8 HIGH — CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-269
Description
Kubernetes CRI-O version prior to 1.9 contains a Privilege Context Switching Error (CWE-270) vulnerability in the handling of ambient capabilities that can result in containers running with elevated privileges, allowing users abilities they should not have. This attack appears to be exploitable via container execution. This vulnerability appears to have been fixed in 1.9.
Affected configurations
• kubernetes cri-o (< 1.9.0)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- http://www.securityfocus.com/bid/104262 Third Party Advisory, VDB Entry
- https://github.com/kubernetes-incubator/cri-o/pull/1558/files Patch, Third Party Advisory
- http://www.securityfocus.com/bid/104262 Third Party Advisory, VDB Entry
- https://github.com/kubernetes-incubator/cri-o/pull/1558/files Patch, Third Party Advisory