CVEvulnerability
CVE-2018-1000401
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-07-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.8 HIGH — CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 2.1 LOW — AV:L/AC:L/Au:N/C:P/I:N/A:N
- Weaknesses
- CWE-522
Description
Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.
Affected configurations
• jenkins aws codepipeline (<= 0.36)
Related
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://jenkins.io/security/advisory/2018-06-25/#SECURITY-967 Vendor Advisory
- https://jenkins.io/security/advisory/2018-06-25/#SECURITY-967 Vendor Advisory