CVEvulnerability
CVE-2018-1000404
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-07-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.8 HIGH — CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 2.1 LOW — AV:L/AC:L/Au:N/C:P/I:N/A:N
- Weaknesses
- CWE-522
Description
Jenkins project Jenkins AWS CodeBuild Plugin version 0.26 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSClientFactory.java, CodeBuilder.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.27 and later.
Affected configurations
• jenkins aws codebuild (<= 0.26)
Related
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://jenkins.io/security/advisory/2018-06-25/#SECURITY-834 Vendor Advisory
- https://jenkins.io/security/advisory/2018-06-25/#SECURITY-834 Vendor Advisory