CVEvulnerability
CVE-2018-1000524
5.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2018-06-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 5.5 MEDIUM — CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-190
Description
miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of service. This attack appear to be exploitable via the victim must load a specially-crafted map which calls SetLayerSize in its entry script. This vulnerability appears to have been fixed in 5.0.3, 5.1.5, 5.2.10 and later.
Affected configurations
• spheredev minisphere (<= 5.2.9)
Related
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness
References
- https://github.com/fatcerberus/minisphere/commit/252c1ca184cb38e1acb917aa0e451c5f08519996 Exploit, Patch, Third Party Advisory
- https://github.com/fatcerberus/minisphere/pull/268 Third Party Advisory
- https://github.com/fatcerberus/minisphere/commit/252c1ca184cb38e1acb917aa0e451c5f08519996 Exploit, Patch, Third Party Advisory
- https://github.com/fatcerberus/minisphere/pull/268 Third Party Advisory