CVEvulnerability

CVE-2018-1000622

7.8 HIGH Published 2018-07-09 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-07-09
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
7.8 HIGH — CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
Weaknesses
CWE-427

Description

The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

Affected configurations

• rust-lang rust (>= 0.8 <= 1.27.0)

Related

Weakness · CWE (1)

  • CWE-427 Uncontrolled Search Path Element weakness

References