CVEvulnerability

CVE-2018-1000807

8.1 HIGH Published 2018-10-08 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-10-08
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
Weaknesses
CWE-416

Description

Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.

Affected configurations

• pyopenssl pyopenssl (< 17.5.0) • canonical ubuntu linux 16.04 • redhat openstack 13 • redhat enterprise linux desktop 7.0 • redhat enterprise linux server 7.0 • redhat enterprise linux workstation 7.0

Related

Weakness · CWE (1)

References