CVEvulnerability
CVE-2018-1000809
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-10-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.5 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-20
Description
privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in Denial-of-Service. This attack appear to be exploitable via http request with user=<space>&pass= to /validate/check url. This vulnerability appears to have been fixed in 2.23.2.
Affected configurations
• privacyidea privacyidea (<= 2.23.1)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/privacyidea/privacyidea/commit/a3edc09beffa2104f357fe24971ea3211ce40751 Patch, Third Party Advisory
- https://github.com/privacyidea/privacyidea/issues/1227 Exploit, Patch, Third Party Advisory
- https://github.com/privacyidea/privacyidea/commit/a3edc09beffa2104f357fe24971ea3211ce40751 Patch, Third Party Advisory
- https://github.com/privacyidea/privacyidea/issues/1227 Exploit, Patch, Third Party Advisory