CVEvulnerability
CVE-2018-11748
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-10-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.8 HIGH — CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 2.1 LOW — AV:L/AC:L/Au:N/C:P/I:N/A:N
- Weaknesses
- CWE-522
Description
Previous releases of the Puppet device_manager module creates configuration files containing credentials that are world readable. This issue has been resolved as of device_manager 2.7.0.
Affected configurations
• puppet device manager (< 2.7.0)
Related
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://puppet.com/security/cve/CVE-2018-11748 Vendor Advisory
- https://puppet.com/security/cve/CVE-2018-11748 Vendor Advisory