CVEvulnerability
CVE-2018-16476
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-11-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.5 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:P/I:N/A:N
- Weaknesses
- CWE-284, CWE-502
Description
A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.
Affected configurations
• rubyonrails rails (>= 4.2.0 < 4.2.11)
• rubyonrails rails (>= 5.0.0 < 5.0.7.1)
• rubyonrails rails (>= 5.1.0 < 5.1.6.1)
• rubyonrails rails (>= 5.2.0 < 5.2.1.1)
• redhat cloudforms 4.6
Related
References
- https://access.redhat.com/errata/RHSA-2019:0600 Third Party Advisory
- https://groups.google.com/d/msg/rubyonrails-security/FL4dSdzr2zw/zjKVhF4qBAAJ Exploit, Mailing List, Mitigation, Third Party Advisory
- https://weblog.rubyonrails.org/2018/11/27/Rails-4-2-5-0-5-1-5-2-have-been-released/ Vendor Advisory
- https://access.redhat.com/errata/RHSA-2019:0600 Third Party Advisory
- https://groups.google.com/d/msg/rubyonrails-security/FL4dSdzr2zw/zjKVhF4qBAAJ Exploit, Mailing List, Mitigation, Third Party Advisory
- https://weblog.rubyonrails.org/2018/11/27/Rails-4-2-5-0-5-1-5-2-have-been-released/ Vendor Advisory