CVEvulnerability

CVE-2018-1999017

4.9 MEDIUM Published 2018-07-23 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-07-23
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
4.9 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0 ([email protected])
4.0 MEDIUM — AV:N/AC:L/Au:S/C:P/I:N/A:N
Weaknesses
CWE-918

Description

Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses "Check Now". This vulnerability appears to have been fixed in 8.2.1.

Affected configurations

• pydio pydio (<= 8.2.0)

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References