CVEvulnerability

CVE-2018-5223

7.2 HIGH Published 2018-03-29 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-03-29
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
7.2 HIGH — CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
Weaknesses
CWE-20

Description

Fisheye and Crucible did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to add a repository in Fisheye or Crucible can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible on the Windows operating system. All versions of Fisheye and Crucible before 4.4.6 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.3 (the fixed version for 4.5.x) are affected by this vulnerability.

Affected configurations

• atlassian fisheye (>= 4.4.0 < 4.4.6) • atlassian fisheye (>= 4.5.0 < 4.5.3) • atlassian crucible (>= 4.4.0 < 4.4.6) • atlassian crucible (>= 4.5.0 < 4.5.3)

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References