CVEvulnerability
CVE-2018-5224
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-03-29
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 8.8 HIGH — CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 9.0 HIGH — AV:N/AC:L/Au:S/C:C/I:C/A:C
- Weaknesses
- CWE-20
Description
Bamboo did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan in Bamboo that has a non-linked Mercurial repository, or create a plan in Bamboo either globally or in a project using Bamboo Specs can can execute code of their choice on systems that run a vulnerable version of Bamboo on the Windows operating system. All versions of Bamboo starting with 2.7.0 before 6.3.3 (the fixed version for 6.3.x) and from version 6.4.0 before 6.4.1 (the fixed version for 6.4.x) running on the Windows operating system are affected by this vulnerability.
Affected configurations
• atlassian bamboo (>= 2.7.0 < 6.3.3)
• atlassian bamboo (>= 6.4.0 < 6.4.1)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- http://www.securityfocus.com/bid/103653 Third Party Advisory, VDB Entry
- https://confluence.atlassian.com/x/PS9sO Mitigation, Vendor Advisory
- https://jira.atlassian.com/browse/BAM-19743 Vendor Advisory
- http://www.securityfocus.com/bid/103653 Third Party Advisory, VDB Entry
- https://confluence.atlassian.com/x/PS9sO Mitigation, Vendor Advisory
- https://jira.atlassian.com/browse/BAM-19743 Vendor Advisory