CVEvulnerability
CVE-2018-9243
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2018-04-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 6.1 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
GitLab Community and Enterprise Editions version 8.4 up to 10.4 are vulnerable to XSS because a lack of input validation in the merge request component leads to cross site scripting (specifically, filenames in changes tabs of merge requests). This is fixed in 10.6.3, 10.5.7, and 10.4.7.
Affected configurations
• gitlab gitlab (>= 8.4 < 10.4.7)
• gitlab gitlab (>= 10.5.0 < 10.5.7)
• gitlab gitlab (>= 10.6.0 < 10.6.3)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://about.gitlab.com/2018/04/04/security-release-gitlab-10-dot-6-dot-3-released/ Vendor Advisory
- https://gitlab.com/gitlab-org/gitlab-ce/issues/42028 Exploit, Vendor Advisory
- https://about.gitlab.com/2018/04/04/security-release-gitlab-10-dot-6-dot-3-released/ Vendor Advisory
- https://gitlab.com/gitlab-org/gitlab-ce/issues/42028 Exploit, Vendor Advisory