CVEvulnerability

CVE-2018-9861

6.1 MEDIUM Published 2018-04-19 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2018-04-19
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
6.1 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0 ([email protected])
4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:N
Weaknesses
CWE-79

Description

Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.

Affected configurations

• ckeditor enhanced image (>= 4.5.10 < 4.9.2) • drupal drupal (>= 8.0.0 < 8.4.7) • drupal drupal (>= 8.5.0 < 8.5.2)

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References