CVEvulnerability

CVE-2019-0226

4.9 MEDIUM Published 2019-05-09 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2019-05-09
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.0 ([email protected])
4.9 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0 ([email protected])
5.5 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:P
Weaknesses
CWE-22

Description

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

Affected configurations

• apache karaf (< 4.2.5)

Related

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References