CVEvulnerability
CVE-2019-1000011
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2019-02-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 6.5 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS 2.0 ([email protected])
- 5.5 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:P
Description
API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in a user authorized to delete a resource can delete any resource. This attack appears to be exploitable via the user must be authorized. This vulnerability appears to have been fixed in 2.3.6.
Affected configurations
• api-platform core (>= 2.2.0 <= 2.3.5)
References
- https://github.com/api-platform/core/issues/2364 Issue Tracking, Third Party Advisory
- https://github.com/api-platform/core/pull/2441 Issue Tracking, Third Party Advisory
- https://github.com/api-platform/core/issues/2364 Issue Tracking, Third Party Advisory
- https://github.com/api-platform/core/pull/2441 Issue Tracking, Third Party Advisory