CVEvulnerability
CVE-2019-1010182
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2019-07-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 6.5 MEDIUM — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-674
Description
yaml-rust 0.4.0 and earlier is affected by: Uncontrolled Recursion. The impact is: Denial of service by impossible to catch abort. The component is: YamlLoader::load_from_str function. The attack vector is: Parsing of a malicious YAML document. The fixed version is: 0.4.1 and later.
Affected configurations
• yaml-rust project yaml-rust (<= 0.4.0)
Related
Weakness · CWE (1)
- CWE-674 Uncontrolled Recursion weakness
References
- https://github.com/chyh1990/yaml-rust/pull/109 Issue Tracking, Patch, Third Party Advisory
- https://github.com/chyh1990/yaml-rust/pull/109 Issue Tracking, Patch, Third Party Advisory