CVEvulnerability

CVE-2019-11253

7.5 HIGH Published 2019-10-17 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2019-10-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
Weaknesses
CWE-20, CWE-776

Description

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.

Affected configurations

• kubernetes kubernetes (>= 1.1.0 <= 1.12.10) • kubernetes kubernetes (>= 1.13.0 < 1.13.12) • kubernetes kubernetes (>= 1.14.0 < 1.14.8) • kubernetes kubernetes (>= 1.15.0 < 1.15.5) • kubernetes kubernetes (>= 1.16.0 < 1.16.2) • redhat openshift container platform 3.9 • redhat openshift container platform 3.10 • redhat openshift container platform 3.11

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-776 Improper Restriction of Recursive Entity References in DTDs weakness

References