CVEvulnerability

CVE-2019-11580

9.8 CRITICAL Known exploited Published 2019-06-03 Modified 2026-06-17 Official page ↗

CISA Known Exploited Vulnerability

Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability — Atlassian Crowd and Crowd Data Center

Atlassian Crowd and Crowd Data Center contain a remote code execution vulnerability resulting from a pdkinstall development plugin being incorrectly enabled in release builds.

Added to KEV
2021-11-03
Remediation due
2022-05-03
Ransomware use
Known
Required action
Apply updates per vendor instructions.
Notes
https://nvd.nist.gov/vuln/detail/CVE-2019-11580
Status
Analyzed
Published
2019-06-03
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P

Description

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

Affected configurations

• atlassian crowd (>= 2.1.0 < 3.0.5) • atlassian crowd (>= 3.1.0 < 3.1.6) • atlassian crowd (>= 3.2.0 < 3.2.8) • atlassian crowd (>= 3.3.0 < 3.3.5) • atlassian crowd (>= 3.4.0 < 3.4.4)

References