CVEvulnerability
CVE-2019-12472
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2019-07-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 7.5 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:N
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Affected configurations
• mediawiki mediawiki (>= 1.18.0 < 1.27.6)
• mediawiki mediawiki (>= 1.30.0 < 1.30.2)
• mediawiki mediawiki (>= 1.31.0 < 1.31.2)
• mediawiki mediawiki (>= 1.32.0 < 1.32.2)
References
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html Patch, Third Party Advisory
- https://phabricator.wikimedia.org/T199540 Issue Tracking, Third Party Advisory
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html Patch, Third Party Advisory
- https://phabricator.wikimedia.org/T199540 Issue Tracking, Third Party Advisory