CVEvulnerability
CVE-2019-13917
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2019-07-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 9.8 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 10.0 HIGH — AV:N/AC:L/Au:N/C:C/I:C/A:C
- Weaknesses
- CWE-19
Description
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).
Affected configurations
• exim exim (>= 4.85 <= 4.92)
• debian debian linux 9.0
• debian debian linux 10.0
Related
Weakness · not in database (1)
References
- http://exim.org/static/doc/security/CVE-2019-13917.txt Patch, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2019/07/26/5 Third Party Advisory
- https://seclists.org/bugtraq/2019/Jul/51 Third Party Advisory
- https://security.gentoo.org/glsa/201909-06 security.gentoo.org
- https://www.debian.org/security/2019/dsa-4488 Third Party Advisory
- http://exim.org/static/doc/security/CVE-2019-13917.txt Patch, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2019/07/26/5 Third Party Advisory
- https://seclists.org/bugtraq/2019/Jul/51 Third Party Advisory
- https://security.gentoo.org/glsa/201909-06 security.gentoo.org
- https://www.debian.org/security/2019/dsa-4488 Third Party Advisory