CVEvulnerability

CVE-2019-15795

4.7 MEDIUM Published 2020-03-26 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-03-26
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
4.7 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1 ([email protected])
4.7 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0 ([email protected])
2.6 LOW — AV:N/AC:H/Au:N/C:N/I:P/A:N
Weaknesses
CWE-327

Description

python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

Affected configurations

• ubuntu python-apt 0.8.0 • ubuntu python-apt 0.8.1 • ubuntu python-apt 0.8.3 • ubuntu python-apt 0.8.9.1 • ubuntu python-apt 0.9.0 • ubuntu python-apt 0.9.1 • ubuntu python-apt 0.9.3.1 • ubuntu python-apt 0.9.3.2 • ubuntu python-apt 0.9.3.3 • ubuntu python-apt 0.9.3.4 • ubuntu python-apt 0.9.3.5 • ubuntu python-apt 1.0.1 • ubuntu python-apt 1.1.0 • debian python-apt 1.8.4 • ubuntu python-apt 1.4.0 • ubuntu python-apt 1.6.0 • ubuntu python-apt 1.6.1 • ubuntu python-apt 1.6.2 • ubuntu python-apt 1.6.3 • ubuntu python-apt 1.6.4 • ubuntu python-apt 1.8.4 • ubuntu python-apt 1.9.0 • ubuntu python-apt 1.7.0 • ubuntu python-apt 1.8.0 • ubuntu python-apt 1.8.1 • ubuntu python-apt 1.8.2 • ubuntu python-apt 1.8.3

Related

Weakness · CWE (1)

  • CWE-327 Use of a Broken or Risky Cryptographic Algorithm weakness

References